PHP IDE Netbeans

De MediaWiki
Saltar a: navegación, buscar

Introdución

  • NetBeans é un IDE có que imos a desenvolver aplicacións en PHP neste curso.
  • Non é obrigatorio utilizalo pudendo usar calquera editor de texto dispoñible ou IDE con soportes para PHP.


Requirimentos previos

  • Un servidor web con soporte para páxinas PHP.
Lembrar que as páxinas PHP teñen que ser cargadas a través dun servidor web, xa que o navegador do cliente non entende o código PHP.
  • O software PHP có intérprete.


Servidor web

  • Aquí temos varias opcións.
  • Dende a versión PHP 5.4, php incorpora un servidor web para facer probas, polo que xa non sería necesaria a instalación dun servidor web 'tradicional' coma Apache.
  • Podemos instalar un servidor web con soporte para PHP, como o servidor web Apache.
Instalación de Apache
  • Podemos instalar un paquete software no que se atopa xa de vez todo o necesario: Servidor web Apache preparado con soporte para PHP e a base de datos Mysql. É o paquete XAMPP.
Instalación paquete XAMPP

Soporte para PHP

Windows

  • O proceso é moi sinxelo.
  • Temos que ter instalado previamente as librerías VC++.
  • Temos que ir á páxina de php.net e descargar a versión correspondente ao noso sistema operativo. Enlace de descarga.
  • Descomprimimos nun cartafol do noso computador. Normalmente sitúase en C:\PHP.
Dentro dese cartafol teremos dous arquivos de nome 'php.ini-development' e 'php.ini-production'.
Como estamos a desenvolver software imos copiar e pegar o arquivo 'php.ini-development' e poñerlle de nome php.ini.
Este arquivo terá entre outros parámetros, activa a directiva que amosará calquera tipo de erro cando carguemos unha páxina php (directiva display_errors = on)
Se a aplicación fora para implantarse nun sitio web, xa funcionando, deberíamos utilizar un php.ini como o que ven no arquivo 'php.ini-production'.


  • Agora debemos editar o arquivo de configuración que se atopa en 'C:\Program Files\Apache Software Foundation\Apache2.2\conf\' (o cartafol pode variar dependendo da versión do servidor web Apache) e dentro deste cartafol debemos editar o arquivo httpd.conf.
  • Por último debemos buscar a liña #LoadModule php5_module "c:/php/php5apache2_2.dll" e quitarlle a símbolo # de diante (a liña pode variar dependende da versión de PHP instalada e da versión do apache). Neste caso asumimos que se descomprimiu o software PHP en C:\php.


  • Buscamos a sección 'DirectoryIndex index.html' e a pasamos a DirectoryIndex index.php index.html


  • Reiniciamos o servizo Apache.

Linux

  • Podemos seguir o proceso indicado neste enlace. Soamente a sección de PHP.

Instalación

  • Primeiro debemos descargar a distribución de PHP que teña soporte para desenvolver aplicacións PHP.
Podemos ver as versións dispoñibles neste enlace
Php ide 1.jpg
  • Debemos escoller o idioma do IDE.
  • Debemos escoller a plataforma do S.O. para o que queiramos instalar.
  • Escolleremos a distribución que teña soporte para PHP.


  • Instalamos o IDE.
  • Nota: Se xa temos instalado o IDE Netbeans, podemos instalar o plugin que nos vai permitir desenvolver proxectos en PHP.
Para iso, imos ao menú Ferramentas => Plugins (en inglés Tools => Plugins), imos a lapela Plugin disponibles, ordenamos por nome premendo na columna nome e seleccionamos o plugin PHP.
Na imaxe xa está instalado e por iso está seleccionada a lapela 'Plugins instalados'.
Php ide 1B.jpg


Instalación Linux

  • Requerimentos:
  • É necesario ter instalado previamente PHP.
O paquete PHP intégrase no servidor APACHE en caso de estar instalado previamente. Desta forma Apache vai poder cargar páxinas PHP.
  • Unha vez descargado o arquivo so teremos que facer os seguinte pasos dende unha terminal de linux:



Instalación Windows

Requirimentos previos

  • En Windows se non temos instalado o XAMPP ou un servidor web con soporte para páxinas PHP, é necesario ter:
  • Desta forma poderemos facer uso do servidor Web interno que incorpora PHP e que se integra dentro do IDE Netbeans.

Configuración

  • Debemos asegurarnos que o Netbeans ten configurada a ruta para que atope o intérprete de PHP.
Para iso imos ao menú Herramientas => Opciones => Lapela PHP:
Php ide 2B.jpg


  • Na imaxe se atopa a ruta do intérprete PHP en Linux. En caso de Windows, deberedes de escoller o cartafol onde descomprimires o software PHP e seleccionar o arquivo PHP.EXE

Primeiro proxecto: Ola Mundo




  • Para inserir código en PHP teremos que escribir dito código entre as etiquetas: <?php  ?>
  • Unha función moi interesante para obter información sobre o Apache e características do PHP instado é: phpinfo()
  1. <html>
  2.     <head>
  3.         <meta charset="UTF-8">
  4.         <title></title>
  5.     </head>
  6.     <body>
  7.         <a href="http://www.google.es">Google</a>
  8.         <?php
  9.  
  10.            phpinfo();
  11.  
  12.        ?>
  13.     </body>
  14. </html>
  • Entre outros informacións danos a ruta do arquivo de configuración que está a utilizar o Apache, como amosa a seguinte imaxe:
Php ide 2.jpg


IMPORTANTE:

  • O NetBeans permite executar as páxinas web utilizando diferentes servidores.
Cando no paso 2 escollimos PHP Built-in Server o php.ini que vai cargar vai ser: etc/php7/cli/php.ini (o podemos saber cargando unha páxina php e chamando á función phpinfo(), xa que pode ser que dependendo da vesión do NetBeans, cambiades de versión PHP).
Polo tanto, se queremos activar o debugger ou calquera outra operación que leve consigo modificar o arquivo php.ini, teremos que ir a esta ruta se estamos a utilizar o PHP Built-in Server.


En caso de estar en Windows, o Netbeans non carga ningún arquivo php.ini.
  • Para que o cargue, unha vez feito o indicado en requirimentos previos, teremos que ir ao menú Herramientas => Opciones => Lapela PHP e poñer a ruta onde se atopa o intérprete có seguinte parámetro: C:\ruta_intérprete\php.exe -c C:\ruta_intérprete\.
  • Saímos do Netbeans e volvemos a entrar. Cargaremos unha páxina có código PHP: phpinfo() e comprobaremos que estamos a cargar o php.ini que se atopa no cartafol onde está o intérprete.



  • Outra opción é utilizar o servidor Apache previamente instalado na máquina.
Php ide 10.jpg
Se no proceso de creación do proxecto escollemos a opción Local Web Site estaríamos utilizando o Apache. Nese caso lembrar que o Apache apunta ao cartafol /var/www/html. Polo tanto o noso proxecto debería estar creado nese cartafol e poderíamos acceder coa seguinte URL: http://localhost/PhpOlaMundo/index.php. Como no paso anterior indicamos que o proxecto se vai crear noutro cartafol, é por iso que aparece a opción de se queremos copiar o proxecto ao onde debería apuntar o Apache (fixerse que a ruta está mal). O mellor nestes casos é crear o proxecto directamente no cartafol onde 'apunta' o Apache.

Configuración do proxecto

  • O IDE permite ter diferentes 'configuracións' de proxectos. Por defecto está unha de nome 'default'.
  • Imos ver onde e como crear novas configuracións.


Activando o modo Debugger

  • NOTA: Esta sección está asociada á realización dun EXERCICIO.


  • Para poder executar o proxecto en Modo Debugger e poder poñer puntos de interrupción teremos que executar o proxecto premendo no botón de Debugger:
Php ide 20.jpg
  • De todas formas con iso non chega xa que é necesario cargar unha librería e configurar o php.ini para activar dita opción.


Instalado XDEBUG EXTENSION FOR PHP

  • Instalaremos o paquete php-pear.
  1. sudo apt-get update
  2. sudo pt-get install php-pear


  • Despois instalamos o módulo xdebug necesario para facer o debugger
  1. sudo apt-get update
  2. sudo apt-get install php5-dev
  3. sudo pecl install xdebug


  • Ao rematar a instalación podemos ver onde gardou a librería compilada.
Php install xdebug 2.JPG
  • Podemos deixala onde está ou copiala ao cartafol /usr/lib

Activando o modo debugger en NetBeans

  • Unha vez instalado, teremos a librería no cartafol: /usr/lib/php5/20121212/xdebug.so
  • Se queremos facer un debugger da aplicación en PHP é necesario engadir unha serie de parámetro no arquivo php.ini.
  • Debemos engadir estas liñas ao arquivo php.ini do apache:
  1. zend_extension=/usr/lib/php5/20121212/xdebug.so
  2. xdebug.remote_enable=1
  3. xdebug.remote_handler=dbgp
  4. xdebug.remote_mode=req
  5. xdebug.remote_host=127.0.0.1
  6. xdebug.remote_port=9000


Nota: É importante poñer a ruta completa onde se atopa a librería xdebug.
  • Finalmente debemos reinicar o servizo apache:


  1. service apache2 restart






-- Ángel D. Fernández González -- (2016).