Diferencia entre revisiones de «PHP IDE Netbeans»
(Página creada con «== Introdución == * [https://netbeans.org/ NetBeans é un [https://es.wikipedia.org/wiki/Entorno_de_desarrollo_integrado IDE] có que imos a desenvolver aplicacións en P...») |
|||
| (No se muestran 35 ediciones intermedias del mismo usuario) | |||
| Línea 1: | Línea 1: | ||
== Introdución == | == Introdución == | ||
| − | * [https://netbeans.org/ NetBeans é un [https://es.wikipedia.org/wiki/Entorno_de_desarrollo_integrado IDE] có que imos a desenvolver aplicacións en PHP neste curso. | + | * [https://netbeans.org/ NetBeans] é un [https://es.wikipedia.org/wiki/Entorno_de_desarrollo_integrado IDE] có que imos a desenvolver aplicacións en PHP neste curso. |
| − | * Non é obrigatorio utilizalo pudendo usar calquera editor de texto dispoñible. | + | * Non é obrigatorio utilizalo pudendo usar calquera editor de texto dispoñible ou IDE con soportes para PHP. |
| + | |||
| + | == Requirimentos previos == | ||
| + | |||
| + | * Un servidor web con soporte para páxinas PHP. | ||
| + | : Lembrar que as páxinas PHP teñen que ser cargadas a través dun servidor web, xa que o navegador do cliente non entende o código PHP. | ||
| + | * O software PHP có intérprete. | ||
| + | |||
| + | |||
| + | === Servidor web === | ||
| + | |||
| + | * Aquí temos varias opcións. | ||
| + | |||
| + | :* Dende a versión PHP 5.4, php incorpora un servidor web para facer probas, polo que xa non sería necesaria a instalación dun servidor web 'tradicional' coma Apache. | ||
| + | :* Podemos instalar un servidor web con soporte para PHP, como o servidor web Apache. | ||
| + | ::: [http://wiki.cifprodolfoucha.es/index.php?title=DRUPAL_Instalaci%C3%B3n#Instalaci.C3.B3n_do_Apache Instalación de Apache] | ||
| + | :* Podemos instalar un paquete software no que se atopa xa de vez todo o necesario: Servidor web Apache preparado con soporte para PHP e a base de datos Mysql. É o paquete XAMPP. | ||
| + | ::: [http://wiki.cifprodolfoucha.es/index.php?title=DRUPAL_Instalaci%C3%B3n#Instalaci.C3.B3n_do_paquete_XAMPP Instalación paquete XAMPP] | ||
| + | |||
| + | === Soporte para PHP === | ||
| + | |||
| + | ==== Windows ==== | ||
| + | |||
| + | * O proceso é moi sinxelo. | ||
| + | |||
| + | :* Temos que ter instalado previamente as [https://www.microsoft.com/es-ES/download/details.aspx?id=48145 librerías VC++]. | ||
| + | :* Temos que ir á páxina de php.net e descargar a versión correspondente ao noso sistema operativo. [http://php.net/downloads.php Enlace de descarga]. | ||
| + | :* Descomprimimos nun cartafol do noso computador. Normalmente sitúase en C:\PHP. | ||
| + | :: Dentro dese cartafol teremos dous arquivos de nome 'php.ini-development' e 'php.ini-production'. | ||
| + | ::: Como estamos a desenvolver software imos copiar e pegar o arquivo 'php.ini-development' e poñerlle de nome '''php.ini'''. | ||
| + | ::: Este arquivo terá entre outros parámetros, activa a directiva que amosará calquera tipo de erro cando carguemos unha páxina php (directiva display_errors = on) | ||
| + | ::: Se a aplicación fora para implantarse nun sitio web, xa funcionando, deberíamos utilizar un php.ini como o que ven no arquivo 'php.ini-production'. | ||
| + | |||
| + | |||
| + | :* Agora debemos editar o arquivo de configuración que se atopa en 'C:\Program Files\Apache Software Foundation\Apache2.2\conf\' (o cartafol pode variar dependendo da versión do servidor web Apache) e dentro deste cartafol debemos editar o arquivo '''httpd.conf'''. | ||
| + | :* Por último debemos buscar a liña '''#LoadModule php5_module "c:/php/php5apache2_2.dll"''' e quitarlle a símbolo # de diante (a liña pode variar dependende da versión de PHP instalada e da versión do apache). Neste caso asumimos que se descomprimiu o software PHP en C:\php. | ||
| + | |||
| + | |||
| + | :* Buscamos a sección 'DirectoryIndex index.html' e a pasamos a '''DirectoryIndex index.php index.html''' | ||
| + | |||
| + | |||
| + | :* Reiniciamos o servizo Apache. | ||
| + | |||
| + | ==== Linux ==== | ||
| + | |||
| + | * Podemos seguir o proceso indicado [http://wiki.cifprodolfoucha.es/index.php?title=DRUPAL_Instalaci%C3%B3n#Instalaci.C3.B3n_do_PHP neste enlace]. Soamente a sección de PHP. | ||
== Instalación == | == Instalación == | ||
| + | |||
| + | * Primeiro debemos descargar a distribución de PHP que teña soporte para desenvolver aplicacións PHP. | ||
| + | : Podemos ver as versións dispoñibles [https://netbeans.org/downloads/index.html neste enlace] | ||
| + | |||
| + | [[Imagen:Php ide 1.jpg|400px|center]] | ||
| + | |||
| + | ::* Debemos escoller o idioma do IDE. | ||
| + | ::* Debemos escoller a plataforma do S.O. para o que queiramos instalar. | ||
| + | ::* Escolleremos a distribución que teña soporte para PHP. | ||
| + | |||
| + | |||
| + | * Instalamos o IDE. | ||
| + | |||
| + | *<u>Nota:</u> Se xa temos instalado o IDE Netbeans, podemos instalar o plugin que nos vai permitir desenvolver proxectos en PHP. | ||
| + | : Para iso, imos ao menú '''Ferramentas''' => '''Plugins''' (en inglés Tools => Plugins), imos a lapela '''Plugin disponibles''', ordenamos por nome premendo na columna nome e seleccionamos o '''plugin PHP'''. | ||
| + | : Na imaxe xa está instalado e por iso está seleccionada a lapela 'Plugins instalados'. | ||
| + | [[Imagen:Php ide 1B.jpg|400px|center]] | ||
| + | |||
| + | |||
| + | === Instalación Linux === | ||
| + | |||
| + | * Requerimentos: | ||
| + | :* É necesario ter instalado previamente PHP. | ||
| + | :: O paquete PHP intégrase no servidor APACHE en caso de estar instalado previamente. Desta forma Apache vai poder cargar páxinas PHP. | ||
| + | :: | ||
| + | * Unha vez descargado o arquivo so teremos que facer os seguinte pasos dende unha terminal de linux: | ||
| + | |||
| + | |||
| + | |||
| + | |||
| + | <gallery caption="Instalando o IDE NetBeans" widths="350" heights="300px" perrow="2"> | ||
| + | Php_ide_21.jpg| Teremos o arquivo descargado no voso /home/usuario/Descargas. | ||
| + | Php_ide_22.jpg| Cambiamos os permisos ao arquivo para que se poida executar (podería facerse graficamente). Escribimos no terminal: '''chmod 755 netbeans-8.2-php-linux-x64.sh''' e despois o executamos coa orde:'''sudo ./netbeans-8.2-php-linux-x64.sh ''' | ||
| + | Php_ide_23.jpg| Empeza o asistente de instalación do IDE. Prememos '''Next'''. | ||
| + | Php_ide_24.jpg| Aceptamos os termos da licenza. | ||
| + | Php_ide_25.jpg| Indicamos o cartafol onde se vai instalar o IDE. | ||
| + | Php_ide_26.jpg| Deixamos marcado o check para que busque actualizacións. Prememos o botón '''Finish'''. | ||
| + | Php_ide_27.jpg| Comeza a instalación. | ||
| + | Php_ide_28.jpg| Prememos o botón '''Finish'''. | ||
| + | Php_ide_29.jpg| Se buscamos polas aplicacións instaladas aparece o ide '''Netbeans Ide 8.2'''. | ||
| + | </gallery> | ||
| + | |||
| + | === Instalación Windows === | ||
| + | |||
| + | ==== Requirimentos previos ==== | ||
| + | |||
| + | * En Windows se non temos instalado o XAMPP ou un servidor web con soporte para páxinas PHP, é necesario ter: | ||
| + | :* Instalado o [http://php.net/downloads.php intérprete de PHP]. | ||
| + | :* As [https://www.microsoft.com/es-ES/download/details.aspx?id=48145 librerías VC++] | ||
| + | |||
| + | * Desta forma poderemos facer uso do servidor Web interno que incorpora PHP e que se integra dentro do IDE Netbeans. | ||
| + | |||
| + | == Configuración == | ||
| + | |||
| + | * Debemos asegurarnos que o Netbeans ten configurada a ruta para que atope o intérprete de PHP. | ||
| + | |||
| + | : Para iso imos ao menú '''Herramientas''' => '''Opciones''' => '''Lapela PHP''': | ||
| + | |||
| + | [[Imagen:Php_ide_2B.jpg|400px|center]] | ||
| + | |||
| + | |||
| + | * Na imaxe se atopa a ruta do intérprete PHP en Linux. En caso de Windows, deberedes de escoller o cartafol onde descomprimires o software PHP e seleccionar o arquivo PHP.EXE | ||
| + | |||
| + | == Primeiro proxecto: Ola Mundo == | ||
| + | |||
| + | |||
| + | * Podemos ver neste enlace como crear o noso primeiro proxecto PHP: http://wiki.netbeans.org/UsandoPHPenNetBeans | ||
| + | |||
| + | |||
| + | |||
| + | |||
| + | <gallery caption="Creando o primeiro proxecto en PHP" widths="350" heights="300px" perrow="2"> | ||
| + | Image:Php_ide_3.jpg| Prememos a opción de menú '''Proxecto''' => '''Novo Proxecto'''. Aparecerá o asistente. Na primeira pantalla escolleremos un proxecto de tipo PHP Application (se non aparece o tipo PHP quere dicir que descargáchedes unha versión do Netbeans incorrecta). | ||
| + | Image:Php_ide_4.jpg| Indicamos o nome do proxecto e a ruta onde se vai gardar así como a versión de PHP que imos utilizar. <u>Escoller a versión php 5.4</u> | ||
| + | Image:Php_ide_5.jpg| Indicamos que servidor web vai executar o proxecto. Inicialmente deixaremos un que trae o propio PHP dende a versión 5.4. ('''IMPORTANTE:''' Ler a nota ao final deste conxunto de pantallas). Prememos o botón '''Terminar'''. | ||
| + | Image:Php_ide_6.jpg| Agora aparecerá na parte esquerda unha estrutura de cartafoles, no que se inclúe o arquivo '''index.php'''. O editamos e engadimos a orde: <b>echo 'ola mundo';</b> | ||
| + | Image:Php_ide_9.jpg| Ao executar o proxecto... | ||
| + | Image:Php_ide_8.jpg| Teremos como resultado a cadena 'ola mundo' no navegador. | ||
| + | </gallery> | ||
| + | |||
| + | |||
| + | * Para inserir código en PHP teremos que escribir dito código entre as etiquetas: '''<?php ?>''' | ||
| + | |||
| + | * Unha función moi interesante para obter información sobre o Apache e características do PHP instado é: phpinfo() | ||
| + | ::<syntaxhighlight lang="xml" line enclose="div" highlight="10" > | ||
| + | <html> | ||
| + | <head> | ||
| + | <meta charset="UTF-8"> | ||
| + | <title></title> | ||
| + | </head> | ||
| + | <body> | ||
| + | <a href="http://www.google.es">Google</a> | ||
| + | <?php | ||
| + | |||
| + | phpinfo(); | ||
| + | |||
| + | ?> | ||
| + | </body> | ||
| + | </html> | ||
| + | |||
| + | </syntaxhighlight> | ||
| + | |||
| + | * Entre outros informacións danos a ruta do arquivo de configuración que está a utilizar o Apache, como amosa a seguinte imaxe: | ||
| + | |||
| + | [[Imagen:Php_ide_2.jpg|400px|center]] | ||
| + | |||
| + | <br/> | ||
| + | |||
| + | <u>'''IMPORTANTE:'''</u> | ||
| + | |||
| + | * O NetBeans permite executar as páxinas web utilizando diferentes servidores. | ||
| + | :: Cando no paso 2 escollimos '''PHP Built-in Server''' o php.ini que vai cargar vai ser: etc/php7/cli/php.ini (o podemos saber cargando unha páxina php e chamando á función phpinfo(), xa que pode ser que dependendo da vesión do NetBeans, cambiades de versión PHP). | ||
| + | :: Polo tanto, se queremos activar o debugger ou calquera outra operación que leve consigo modificar o arquivo php.ini, teremos que ir a esta ruta se estamos a utilizar o PHP Built-in Server. | ||
| + | |||
| + | |||
| + | :: En caso de <u>estar en Windows</u>, o Netbeans non carga ningún arquivo php.ini. | ||
| + | ::* Primeiro deberemos crear dito arquivo. Na instalación en windows temos dous arquivos php.ini que podemos usar e que se atopan no cartafol onde está descomprimido o intérprete php: | ||
| + | :::* php.ini-develop: versión para probas. Nesta versión está activada a directiva que amosa os erros que se poidan dar así como avisos. | ||
| + | :::* php.ini-production: esta versión é que deberíamos utilizar en caso de que xa rematáramos de desenvolver o proxecto. | ||
| + | |||
| + | ::: O que temos que facer e copiar un dos arquivos (nos utilizaremos php-ini-devevlop) como php.ini. | ||
| + | ::: Desta forma xa debería de coller este arquivo de configuración. Podemos comprobalo chamando á función phpinfo() como fixemos antes. | ||
| + | ::: No caso de que non o cargue teremos que modificar a configuración de NetBeans: Ir ao menú '''Herramientas''' => '''Opciones''' => '''Lapela PHP''' e poñer a ruta onde se atopa o intérprete có seguinte parámetro: C:\ruta_intérprete\php.exe '''-c C:\ruta_intérprete\'''. | ||
| + | ::* Saímos do Netbeans e volvemos a entrar (ou pechamos o servidor web php se o temos iniciado). Cargaremos unha páxina có código PHP: phpinfo() e comprobaremos que estamos a cargar o php.ini que se atopa no cartafol onde está o intérprete. | ||
| + | |||
| + | |||
| + | * Outra opción é utilizar o servidor Apache previamente instalado na máquina. | ||
| + | [[Imagen:Php_ide_10.jpg|400px|center]] | ||
| + | : Se no proceso de creación do proxecto escollemos a opción '''Local Web Site''' estaríamos utilizando o Apache. Nese caso lembrar que o Apache apunta ao cartafol '''/var/www/html'''. Polo tanto o noso proxecto debería estar creado nese cartafol e poderíamos acceder coa seguinte URL: '''http://localhost/PhpOlaMundo/index.php'''. Como no paso anterior indicamos que o proxecto se vai crear noutro cartafol, é por iso que aparece a opción de se queremos copiar o proxecto ao onde debería apuntar o Apache (fixerse que a ruta está mal). O mellor nestes casos é crear o proxecto directamente no cartafol onde 'apunta' o Apache. | ||
| + | |||
| + | == Configuración do proxecto == | ||
| + | |||
| + | * O IDE permite ter diferentes 'configuracións' de proxectos. Por defecto está unha de nome 'default'. | ||
| + | * Imos ver onde e como crear novas configuracións. | ||
| + | |||
| + | <gallery caption="Configuración de proxectos" widths="350" heights="300px" perrow="2"> | ||
| + | Image:Php_ide_11.jpg| Premendo na lista da sección superior podemos ver como temos unha configuración 'default' creada. Prememos a opción '''Personalizar'''. | ||
| + | Image:Php_ide_12.jpg| Como vemos esta é a configuración na que entre outras cousas, executamos o proxecto no 'Php built-in Server'. Imos crear unha nova para executar o proxecto có servidor web Apache. Na parte esquerda temos múltiples opcións de configuración que os seus valores quedarían gardados para cada configuración que cremos. Prememos o botón '''New'''. | ||
| + | Image:Php_ide_13.jpg| Dámoslle un nome á nova configuración. | ||
| + | Image:Php_ide_14.jpg| Indicamos que imos a utilizar o servidor web local (o Apache instalado). <br/>Indicamos a url. Como o proxecto ten de nome PhpOlaMundo, teremos un cartafol có mesmo nome. Polo tanto a ruta deberá ser: http://localhost/PhpOlaMundo/ <br/> Indicamos a páxina que queremos que se cargue por defecto. Prememos o botón '''Aceptar''' | ||
| + | Image:Php_ide_15.jpg| Agora na parte superior teremos dúas configuracións. A default e a que creamos no paso anterior. En calquera momento podemos editalas premendo na opción '''Personalizar'''. | ||
| + | Image:Php_ide_16.jpg| Se intentamos executar o proxecto dará un erro xa que dito proxecto segue gardado na ruta onde Netbeans os crea por defecto. Polo tanto teremos que movelo ao cartafol do Apache como indicamos antes. <br/> Neste intre temos dúas opcións, mover os arquivos (en Linux: mv /home/angel/NetBeansProjects/PhpOlaMundo/ /var/www/html/), pechar o Netbeans e volver abrir o proxecto na nova localización ou ter dúas copias do proxecto, unha onde se crea por defecto e outra onde o Apache carga as páxinas. Automaticamente o Netbeans copiaría os cambios dunha a outra. | ||
| + | Image:Php_ide_17.jpg| Prememos o botón dereito sobre o proxecto e escollemos a opción de '''Propiedades'''. | ||
| + | Image:Php_ide_18.jpg| Indicamos a ruta onde se vai copiar o proxecto. <u>Nota:</u> Se vos aparece un erro de que non se pode copiar o proxecte deberedes dar permiso de escritura ao voso usuario no cartafol /var/www/html. | ||
| + | Image:Php_ide_19.jpg| Ao executar o proxecto podedes comprobar como xa aparece a páxina e fisicamente aparece o cartafol na ruta do Apache. | ||
| + | |||
| + | |||
| + | |||
| + | |||
| + | |||
| + | |||
| + | |||
| + | |||
| + | |||
| + | </gallery> | ||
| Línea 12: | Línea 212: | ||
== Activando o modo Debugger == | == Activando o modo Debugger == | ||
| − | |||
| − | * | + | * <u>'''NOTA:'''</u> '''Esta sección está asociada á realización dun EXERCICIO.''' |
| + | |||
| + | |||
| + | |||
| + | * Para poder executar o proxecto en Modo Debugger e poder poñer puntos de interrupción teremos que executar o proxecto premendo no '''botón de Debugger''': | ||
| + | |||
| + | [[Imagen:Php_ide_20.jpg|400px|center]] | ||
| + | |||
| + | * De todas formas con iso non chega xa que é necesario cargar unha librería e configurar o php.ini para activar dita opción. | ||
| + | |||
| + | |||
| + | === Instalado XDEBUG EXTENSION FOR PHP === | ||
| + | |||
| + | * Primeiro debemos ter instalado [https://xdebug.org/ XDEBUG EXTENSION FOR PHP]. | ||
| + | |||
| + | * Instalaremos o paquete '''php-pear'''. | ||
| + | |||
| + | ::<syntaxhighlight lang="java" line enclose="div" highlight="" > | ||
| + | sudo apt-get update | ||
| + | sudo pt-get install php-pear | ||
| + | </syntaxhighlight> | ||
| + | |||
| + | |||
| + | * Despois instalamos o módulo xdebug necesario para facer o debugger | ||
| + | ::<syntaxhighlight lang="java" line enclose="div" highlight="" > | ||
| + | sudo apt-get update | ||
| + | sudo apt-get install php5-dev | ||
| + | sudo pecl install xdebug | ||
| + | </syntaxhighlight> | ||
| + | |||
| + | |||
| + | * Ao rematar a instalación podemos ver onde gardou a librería compilada. | ||
| + | |||
| + | [[Imagen:Php_install_xdebug_2.JPG|400px|center]] | ||
| + | |||
| + | * Podemos deixala onde está ou copiala ao cartafol /usr/lib | ||
| + | |||
| + | === Activando o modo debugger en NetBeans === | ||
| + | |||
| + | * Unha vez instalado, teremos a librería no cartafol: '''/usr/lib/php5/20121212/xdebug.so''' | ||
| + | * Se queremos facer un debugger da aplicación en PHP é necesario engadir unha serie de parámetro no arquivo '''php.ini'''. | ||
| + | * Podemos ver un vídeo explicativo neste enlace: https://www.youtube.com/watch?v=k4ByadtSra8 | ||
| + | * Podemos ver que liñas engadir neste enlace: http://wiki.netbeans.org/HowToConfigureXDebug#How_to_on_Linux | ||
| + | * Debemos engadir estas liñas ao arquivo php.ini do apache: | ||
| + | ::<syntaxhighlight lang="java" line enclose="div" highlight="" > | ||
| + | zend_extension=/usr/lib/php5/20121212/xdebug.so | ||
| + | xdebug.remote_enable=1 | ||
| + | xdebug.remote_handler=dbgp | ||
| + | xdebug.remote_mode=req | ||
| + | xdebug.remote_host=127.0.0.1 | ||
| + | xdebug.remote_port=9000 | ||
| + | </syntaxhighlight> | ||
| + | : <u>Nota:</u> É importante poñer a ruta completa onde se atopa a librería xdebug. | ||
| + | * Finalmente debemos reinicar o servizo apache: | ||
| + | ::<syntaxhighlight lang="java" line enclose="div" highlight="" > | ||
| + | service apache2 restart | ||
| + | </syntaxhighlight> | ||
Revisión actual del 14:29 30 mar 2017
Sumario
Introdución
- Non é obrigatorio utilizalo pudendo usar calquera editor de texto dispoñible ou IDE con soportes para PHP.
Requirimentos previos
- Un servidor web con soporte para páxinas PHP.
- Lembrar que as páxinas PHP teñen que ser cargadas a través dun servidor web, xa que o navegador do cliente non entende o código PHP.
- O software PHP có intérprete.
Servidor web
- Aquí temos varias opcións.
- Dende a versión PHP 5.4, php incorpora un servidor web para facer probas, polo que xa non sería necesaria a instalación dun servidor web 'tradicional' coma Apache.
- Podemos instalar un servidor web con soporte para PHP, como o servidor web Apache.
- Podemos instalar un paquete software no que se atopa xa de vez todo o necesario: Servidor web Apache preparado con soporte para PHP e a base de datos Mysql. É o paquete XAMPP.
Soporte para PHP
Windows
- O proceso é moi sinxelo.
- Temos que ter instalado previamente as librerías VC++.
- Temos que ir á páxina de php.net e descargar a versión correspondente ao noso sistema operativo. Enlace de descarga.
- Descomprimimos nun cartafol do noso computador. Normalmente sitúase en C:\PHP.
- Dentro dese cartafol teremos dous arquivos de nome 'php.ini-development' e 'php.ini-production'.
- Como estamos a desenvolver software imos copiar e pegar o arquivo 'php.ini-development' e poñerlle de nome php.ini.
- Este arquivo terá entre outros parámetros, activa a directiva que amosará calquera tipo de erro cando carguemos unha páxina php (directiva display_errors = on)
- Se a aplicación fora para implantarse nun sitio web, xa funcionando, deberíamos utilizar un php.ini como o que ven no arquivo 'php.ini-production'.
- Agora debemos editar o arquivo de configuración que se atopa en 'C:\Program Files\Apache Software Foundation\Apache2.2\conf\' (o cartafol pode variar dependendo da versión do servidor web Apache) e dentro deste cartafol debemos editar o arquivo httpd.conf.
- Por último debemos buscar a liña #LoadModule php5_module "c:/php/php5apache2_2.dll" e quitarlle a símbolo # de diante (a liña pode variar dependende da versión de PHP instalada e da versión do apache). Neste caso asumimos que se descomprimiu o software PHP en C:\php.
- Buscamos a sección 'DirectoryIndex index.html' e a pasamos a DirectoryIndex index.php index.html
- Reiniciamos o servizo Apache.
Linux
- Podemos seguir o proceso indicado neste enlace. Soamente a sección de PHP.
Instalación
- Primeiro debemos descargar a distribución de PHP que teña soporte para desenvolver aplicacións PHP.
- Podemos ver as versións dispoñibles neste enlace
- Debemos escoller o idioma do IDE.
- Debemos escoller a plataforma do S.O. para o que queiramos instalar.
- Escolleremos a distribución que teña soporte para PHP.
- Instalamos o IDE.
- Nota: Se xa temos instalado o IDE Netbeans, podemos instalar o plugin que nos vai permitir desenvolver proxectos en PHP.
- Para iso, imos ao menú Ferramentas => Plugins (en inglés Tools => Plugins), imos a lapela Plugin disponibles, ordenamos por nome premendo na columna nome e seleccionamos o plugin PHP.
- Na imaxe xa está instalado e por iso está seleccionada a lapela 'Plugins instalados'.
Instalación Linux
- Requerimentos:
- É necesario ter instalado previamente PHP.
- O paquete PHP intégrase no servidor APACHE en caso de estar instalado previamente. Desta forma Apache vai poder cargar páxinas PHP.
- Unha vez descargado o arquivo so teremos que facer os seguinte pasos dende unha terminal de linux:
- Instalando o IDE NetBeans
Instalación Windows
Requirimentos previos
- En Windows se non temos instalado o XAMPP ou un servidor web con soporte para páxinas PHP, é necesario ter:
- Instalado o intérprete de PHP.
- As librerías VC++
- Desta forma poderemos facer uso do servidor Web interno que incorpora PHP e que se integra dentro do IDE Netbeans.
Configuración
- Debemos asegurarnos que o Netbeans ten configurada a ruta para que atope o intérprete de PHP.
- Para iso imos ao menú Herramientas => Opciones => Lapela PHP:
- Na imaxe se atopa a ruta do intérprete PHP en Linux. En caso de Windows, deberedes de escoller o cartafol onde descomprimires o software PHP e seleccionar o arquivo PHP.EXE
Primeiro proxecto: Ola Mundo
- Podemos ver neste enlace como crear o noso primeiro proxecto PHP: http://wiki.netbeans.org/UsandoPHPenNetBeans
- Creando o primeiro proxecto en PHP
- Para inserir código en PHP teremos que escribir dito código entre as etiquetas: <?php ?>
- Unha función moi interesante para obter información sobre o Apache e características do PHP instado é: phpinfo()
1 <html> 2 <head> 3 <meta charset="UTF-8"> 4 <title></title> 5 </head> 6 <body> 7 <a href="http://www.google.es">Google</a> 8 <?php 9 10 phpinfo(); 11 12 ?> 13 </body> 14 </html>
- Entre outros informacións danos a ruta do arquivo de configuración que está a utilizar o Apache, como amosa a seguinte imaxe:
IMPORTANTE:
- O NetBeans permite executar as páxinas web utilizando diferentes servidores.
- Cando no paso 2 escollimos PHP Built-in Server o php.ini que vai cargar vai ser: etc/php7/cli/php.ini (o podemos saber cargando unha páxina php e chamando á función phpinfo(), xa que pode ser que dependendo da vesión do NetBeans, cambiades de versión PHP).
- Polo tanto, se queremos activar o debugger ou calquera outra operación que leve consigo modificar o arquivo php.ini, teremos que ir a esta ruta se estamos a utilizar o PHP Built-in Server.
- En caso de estar en Windows, o Netbeans non carga ningún arquivo php.ini.
- Primeiro deberemos crear dito arquivo. Na instalación en windows temos dous arquivos php.ini que podemos usar e que se atopan no cartafol onde está descomprimido o intérprete php:
- php.ini-develop: versión para probas. Nesta versión está activada a directiva que amosa os erros que se poidan dar así como avisos.
- php.ini-production: esta versión é que deberíamos utilizar en caso de que xa rematáramos de desenvolver o proxecto.
- En caso de estar en Windows, o Netbeans non carga ningún arquivo php.ini.
- O que temos que facer e copiar un dos arquivos (nos utilizaremos php-ini-devevlop) como php.ini.
- Desta forma xa debería de coller este arquivo de configuración. Podemos comprobalo chamando á función phpinfo() como fixemos antes.
- No caso de que non o cargue teremos que modificar a configuración de NetBeans: Ir ao menú Herramientas => Opciones => Lapela PHP e poñer a ruta onde se atopa o intérprete có seguinte parámetro: C:\ruta_intérprete\php.exe -c C:\ruta_intérprete\.
- Saímos do Netbeans e volvemos a entrar (ou pechamos o servidor web php se o temos iniciado). Cargaremos unha páxina có código PHP: phpinfo() e comprobaremos que estamos a cargar o php.ini que se atopa no cartafol onde está o intérprete.
- Outra opción é utilizar o servidor Apache previamente instalado na máquina.
- Se no proceso de creación do proxecto escollemos a opción Local Web Site estaríamos utilizando o Apache. Nese caso lembrar que o Apache apunta ao cartafol /var/www/html. Polo tanto o noso proxecto debería estar creado nese cartafol e poderíamos acceder coa seguinte URL: http://localhost/PhpOlaMundo/index.php. Como no paso anterior indicamos que o proxecto se vai crear noutro cartafol, é por iso que aparece a opción de se queremos copiar o proxecto ao onde debería apuntar o Apache (fixerse que a ruta está mal). O mellor nestes casos é crear o proxecto directamente no cartafol onde 'apunta' o Apache.
Configuración do proxecto
- O IDE permite ter diferentes 'configuracións' de proxectos. Por defecto está unha de nome 'default'.
- Imos ver onde e como crear novas configuracións.
- Configuración de proxectos
Como vemos esta é a configuración na que entre outras cousas, executamos o proxecto no 'Php built-in Server'. Imos crear unha nova para executar o proxecto có servidor web Apache. Na parte esquerda temos múltiples opcións de configuración que os seus valores quedarían gardados para cada configuración que cremos. Prememos o botón New.
Indicamos que imos a utilizar o servidor web local (o Apache instalado).
Indicamos a url. Como o proxecto ten de nome PhpOlaMundo, teremos un cartafol có mesmo nome. Polo tanto a ruta deberá ser: http://localhost/PhpOlaMundo/
Indicamos a páxina que queremos que se cargue por defecto. Prememos o botón AceptarSe intentamos executar o proxecto dará un erro xa que dito proxecto segue gardado na ruta onde Netbeans os crea por defecto. Polo tanto teremos que movelo ao cartafol do Apache como indicamos antes.
Neste intre temos dúas opcións, mover os arquivos (en Linux: mv /home/angel/NetBeansProjects/PhpOlaMundo/ /var/www/html/), pechar o Netbeans e volver abrir o proxecto na nova localización ou ter dúas copias do proxecto, unha onde se crea por defecto e outra onde o Apache carga as páxinas. Automaticamente o Netbeans copiaría os cambios dunha a outra.
Activando o modo Debugger
- NOTA: Esta sección está asociada á realización dun EXERCICIO.
- Para poder executar o proxecto en Modo Debugger e poder poñer puntos de interrupción teremos que executar o proxecto premendo no botón de Debugger:
- De todas formas con iso non chega xa que é necesario cargar unha librería e configurar o php.ini para activar dita opción.
Instalado XDEBUG EXTENSION FOR PHP
- Primeiro debemos ter instalado XDEBUG EXTENSION FOR PHP.
- Instalaremos o paquete php-pear.
1 sudo apt-get update 2 sudo pt-get install php-pear
- Despois instalamos o módulo xdebug necesario para facer o debugger
1 sudo apt-get update 2 sudo apt-get install php5-dev 3 sudo pecl install xdebug
- Ao rematar a instalación podemos ver onde gardou a librería compilada.
- Podemos deixala onde está ou copiala ao cartafol /usr/lib
Activando o modo debugger en NetBeans
- Unha vez instalado, teremos a librería no cartafol: /usr/lib/php5/20121212/xdebug.so
- Se queremos facer un debugger da aplicación en PHP é necesario engadir unha serie de parámetro no arquivo php.ini.
- Podemos ver un vídeo explicativo neste enlace: https://www.youtube.com/watch?v=k4ByadtSra8
- Podemos ver que liñas engadir neste enlace: http://wiki.netbeans.org/HowToConfigureXDebug#How_to_on_Linux
- Debemos engadir estas liñas ao arquivo php.ini do apache:
1 zend_extension=/usr/lib/php5/20121212/xdebug.so 2 xdebug.remote_enable=1 3 xdebug.remote_handler=dbgp 4 xdebug.remote_mode=req 5 xdebug.remote_host=127.0.0.1 6 xdebug.remote_port=9000
- Nota: É importante poñer a ruta completa onde se atopa a librería xdebug.
- Finalmente debemos reinicar o servizo apache:
1 service apache2 restart
-- Ángel D. Fernández González -- (2016).