UNITY Requisitos previos

De MediaWiki
Ir a la navegación Ir a la búsqueda

Introdución

  • Va a depender de la versión de Unity a descargar.
  • La versión seguida en este manual va a ser la 2018.1.3 sobre S.O. Windows 10.




Para desarrollo

  • Sistema operativo:
  • Windows 7 SP1+, 8, 10, solo versiones de 64 bits.
  • Mac OS X 10.9+.
  • Windows XP y Vista no son compatibles; y las versiones de servidor de Windows & OS X no se han probado.
  • CPU: Soporte para el conjunto de instrucciones SSE2.
  • GPU: Tarjeta gráfica con DX9 (modelo de shader 3.0) o DX11 con capacidades de funciones de nivel 9.3.
  • El resto depende principalmente de la complejidad de los proyectos.
Requisitos adicionales que necesitaremos para desarrollar juegos para alguna de las siguientes plataformas:
  • iOS: Computadora Mac con sistema operativo versión OS X 10.9.4 como mínimo y Xcode 7.0 o superior.
  • Android: Kit de desarrollo Android SDK y Java (JDK); el IL2CPP scripting backend requiere Android NDK.
  • Windows Store: Windows 8.1 (64 bits) y Visual Studio y plataforma SDK correspondiente:
  • Universal Windows Platform (UWP): Windows 8.1 (64 bits), Visual Studio 2015 o posterior y Windows 10 SDK;
El scripting backend IL2CPP también requiere la instalación de la función de compilador C++ con Visual Studio.


  • Lo recomendable sería:
  • Un procesador Intel Core i5, i7 o Xeon comprados a partir del 2012
  • Memoria: 8GB RAM
  • Actualizado a 2018:
  • Están desarrollando el entorno para que pueda ser ejecutado en Linux.
En el punto de instalación de esta Wiki se indica como instalarlo.



Para jugar

  • Por lo general, el contenido desarrollado con Unity puede ejecutarse bastante bien en todas partes. Qué tan bien se ejecuta depende de la complejidad de su proyecto. Requisitos más detallados:
  • Para escritorio:
  • Sistema operativo: Windows XP SP2+, Mac OS X 10.9+, Ubuntu 12.04+, SteamOS+.
  • Tarjeta gráfica: DX9 (modelo de shader 3.0) o DX11 con capacidades de funciones de nivel 9.3.
  • CPU: compatible con el conjunto de instrucciones SSE2.
  • El reproductor de iOS requiere iOS 7.0 o una versión superior.
  • Android: OS 4.1 o posterior; ARMv7 CPU con soporte NEON o CPU Atom; OpenGL ES 2.0 o posterior.
  • WebGL: Cualquier versión de escritorio reciente de Firefox, Chrome, Edge o Safari
  • Windows Phone: 8.1 o posterior.
  • Windows Store Apps: 8.1 o posterior.











-- Ángel D. Fernández González -- (2018).